Adobe Won't Support Flash On Android 4.1, Will Discontinue New Flash Installs In August

rated by 0 users
This post has 1 Reply | 0 Followers

Top 10 Contributor
Posts 24,911
Points 1,117,760
Joined: Sep 2007
ForumsAdministrator
News Posted: Fri, Jun 29 2012 11:57 AM

Last November, Adobe announced plans to discontinue development of the Flash Player for mobile devices. Now, Adobe is letting users know a little bit more about what they can expect moving forward. For starters, Adobe will not be offering any certified implementations of Flash Player for Android 4.1. In addition, starting August 15th, Adobe plans to use the configuration settings in the Google Play Store to limit access to Flash Player updates to devices that already have Flash player installed. In other words, if you want Flash Player on your Android phone and you don't already have it, make sure you install it before August 15.

An Update on Flash Player and Android

We announced last November that we are focusing our work with Flash on PC browsing and mobile apps packaged with Adobe AIR, and will be discontinuing our development of the Flash Player for mobile browsers.  This post provides an update on what this means for ongoing access to the Flash Player browser plugin for Android in the Google Play Store.

The Flash Player browser plugin integrates tightly with a device’s browser and multimedia subsystems (in ways that typical apps do not), and this necessitates integration by our device ecosystem partners.  To ensure that  the Flash Player provides the best possible experience for users, our partner program requires certification of each Flash Player implementation.  Certification includes extensive testing to ensure web content works as expected, and that the Flash Player provides a good user experience. Certified devices typically include the Flash Player pre-loaded at the factory or as part of a system update.

Devices that don’t have the Flash Player provided by the manufacturer typically are uncertified, meaning the manufacturer has not completed the certification testing requirements. In many cases users of uncertified devices have been able to download the Flash Player from the Google Play Store, and in most cases it worked. However, with Android 4.1 this is no longer going to be the case, as we have not continued developing and testing Flash Player for this new version of Android and its available browser options.  There will be no certified implementations of Flash Player for Android 4.1.

Beginning August 15th we will use the configuration settings in the Google Play Store to limit continued access to Flash Player updates to only those devices that have Flash Player already installed. Devices that do not have Flash Player already installed are increasingly likely to be incompatible with Flash Player and will no longer be able to install it from the Google Play Store after August 15th.

The easiest way to ensure ongoing access to Flash Player on Android 4.0 or earlier devices is to use certified devices and ensure that the Flash Player is either pre-installed by the manufacturer or installed from Google Play Store before August 15th. If a device is upgraded from Android 4.0 to Android 4.1, the current version of Flash Player may exhibit unpredictable behavior, as it is not certified for use with Android 4.1.  Future updates to Flash Player will not work.  We recommend uninstalling Flash Player on devices which have been upgraded to Android 4.1.

For developers who need ongoing access to released versions of Flash Player for Android, those will remain available in the archive of released Flash Player versions.  Installations made from the archive will not receive updates through the Google Play Store.

As always this and other Flash runtime roadmap updates can be found in the Adobe roadmap for the Flash runtimes white paper.

  • | Post Points: 20
Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Fri, Jun 29 2012 2:10 PM

I wouldn't expect this to be any issue, since Google already took over development of Flash on the Linux platforms and supports it via their own pepper plugin since Chrome 20.

Adobe support of the platform was always atrocious anyway, so good riddance I say; HTML5 can't kill it soon enough.

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

  • | Post Points: 5
Page 1 of 1 (2 items) | RSS