[SOLVED]What is this OpenAL32.dll error ?

rated by 0 users
This post has 7 Replies | 1 Follower

Top 500 Contributor
Posts 209
Points 3,575
Joined: Feb 2008
wolf2009 Posted: Thu, Feb 28 2008 10:52 PM

I get this error while trying to launch The Club game.



I placed openal32.dll in windows\system directory but still get this error .

When i try to install openal i get this error , even after reboot .



My PC :

ASUS A7N8X Mobo nforce2 chipset , Win XP , AMD AthlonXP 2800+ Barton , 1 GB DDR333 RAM .

  • | Post Points: 35
Top 150 Contributor
Posts 795
Points 13,650
Joined: Feb 2008
Location: Reseda
Kamrooz replied on Fri, Feb 29 2008 12:28 AM

OpenAL is the new audio system used in Vista. Directsound has been dropped in Vista and has moved towards OpenAL. 

I'm not that experienced with it in terms of gaming. I gave a quick google search and found this...Don't know if this relates to your probably...but hopefully it does...

 http://www.hard-light.net/forums/index.php?topic=45549.msg929042

2x Core 2 Quad QX9775 2Gb DDR2-667 Kingston FBDimm 150GB Western Digital Raptor 2x 500 Gb Seagate 7200.10 2x 8800 GT SLI Intel D5400XS (Skulltrail) Gigabyte 3D Aurora 570 Ultra X3 1KW psu 2X Liteon DL DVD-RW Rig courtesy of HotHardware! =D
  • | Post Points: 20
replied on Fri, Feb 29 2008 5:37 AM

It is possible your sound card doesnt' support OpenAL for 3d sound. In this case check the folder of the club and see if there is a configuration utility to launch and change from openal to software or some other option and try again.

  • | Post Points: 5
Top 500 Contributor
Posts 209
Points 3,575
Joined: Feb 2008
wolf2009 replied on Fri, Feb 29 2008 9:41 AM

thx  man , that worked .  

  • | Post Points: 20
replied on Fri, Feb 29 2008 10:39 AM

just for clarification what worked ?

  • | Post Points: 20
Top 500 Contributor
Posts 209
Points 3,575
Joined: Feb 2008
wolf2009 replied on Fri, Feb 29 2008 11:03 AM

i did what the guy in the 2nd post pointed me to , and its installed now . 

  • | Post Points: 20
replied on Fri, Feb 29 2008 11:20 AM

good I will keep this in my memory for future reference.

  • | Post Points: 20
Top 150 Contributor
Posts 795
Points 13,650
Joined: Feb 2008
Location: Reseda
Kamrooz replied on Fri, Feb 29 2008 9:05 PM

Anytime Wolf ^_^..

The problems sounded similar....So I thought maybe it was a good go =P. I was thinking the same thing though brian, regarding drivers and incompatibility for his onboard sound, I typed it out, but then decided to google search before I posted. But thankfully google gave me something useful =D. 

2x Core 2 Quad QX9775 2Gb DDR2-667 Kingston FBDimm 150GB Western Digital Raptor 2x 500 Gb Seagate 7200.10 2x 8800 GT SLI Intel D5400XS (Skulltrail) Gigabyte 3D Aurora 570 Ultra X3 1KW psu 2X Liteon DL DVD-RW Rig courtesy of HotHardware! =D
  • | Post Points: 5
Page 1 of 1 (8 items) | RSS