GPT vs. Windows 7. How to make Windows 7 ignore a drive?

This post has 4 Replies | 3 Followers

Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 Posted: Mon, Mar 7 2011 7:17 PM

I have a very large USB3 drive that I use with my Linux system.  It is using a GPT partition table, because it contains a 4TB Btrfs partition.

Here's the problem:  If I dual-boot my system over to Windows, it immediately pops up a dialog saying "Drive I: must be formatted before use." and then sets focus on the "Format now" button.   The dialog popped up a half dozen times when I was trying to use the file manager to troubleshoot a different NTFS drive issue yesterday (which I eventually fixed by rebooting back to Linux and running the ntfsfix command).  It's annoying, and it scares the hell out of me that I might accidentally be hitting enter when that window pops up (hopefully there's some confirmation prompt after that button).

I think Win7 is supposed to support GPT, but it probably doesn't have any idea that the Btrfs partition is valid (and way better than NTFS).  So, here's my question:  Anyone know a registry hack or simple tweak where I could make Win7 ignore this drive entirely?

It's not a major problem, as I stay booted into Linux without rebooting for months on end - but I'd really like to avoid any chance that Win7 might torch my network backups on the one blue moon I start it.

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

Top 50 Contributor
Posts 2,365
Points 30,865
Joined: Nov 2010
Location: Crystal Lake,IL
rrplay replied on Mon, Mar 7 2011 8:18 PM

You can try to disable  the drive from the Device Manager.in Win 7

No need to uninstall the driver, no need to hack the registry,

its simple & may be what you are looking for.

lots more aditional info here for other solutions

http://www.howtogeek.com/howto/windows-vista/hide-drives-from-your-computer-in-windows-vista/

 

"Don't Panic ! 'cause HH got's your back!"

  • | Post Points: 35
Top 10 Contributor
Posts 8,436
Points 102,150
Joined: Apr 2009
Location: Shenandoah Valley, Virginia
MembershipAdministrator
Moderator

Windows automatically see's and mounts a drive that it thinks is new. Automatic actions need to be changed.

Navigate to: Control Panel,.....All Control Panel Items,......then to "AutoPlay".

Once you're there, uncheck the "use Autoplay for all media devices" box and try it out.

Don't part with your illusions. When they are gone you may still exist, but you have ceased to live.

(Mark Twain)

  • | Post Points: 5
Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Wed, Mar 9 2011 9:56 PM

Thx rrplay - I guess my Win skillz must be getting quite rusty for me not to think of such an obvious solution.  Disabling the drive in Device Mangler worked fine.

Appreciate the assist!

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

  • | Post Points: 20
Top 50 Contributor
Posts 2,365
Points 30,865
Joined: Nov 2010
Location: Crystal Lake,IL
rrplay replied on Thu, Mar 10 2011 7:54 AM

3vi1:

Thx rrplay - I guess my Win skillz must be getting quite rusty for me not to think of such an obvious solution.  Disabling the drive in Device Mangler worked fine.

Appreciate the assist!

Just a note that should be mentioned

there is a difference in disabling the drive for Current  User and system admin

disabling the drive in Device Manager with full Admin privileges will revoke the drive;s access to all users.

 

 

 

"Don't Panic ! 'cause HH got's your back!"

  • | Post Points: 5
Page 1 of 1 (5 items) | RSS