3vi1 Help me!!(or anyone else) VirtualBox 3.0 Ubuntu guest troubles.

rated by 0 users
This post has 8 Replies | 2 Followers

Top 10 Contributor
Posts 6,181
Points 90,135
Joined: Aug 2003
Location: United States, Virginia
Moderator
bob_on_the_cob Posted: Fri, Jul 3 2009 11:21 PM

So I saw that Virtualbox now supports 3D with a linux guest and I wanted to try and see if I could run compiz with Ubuntu as the guest, but I can't get it to boot Ubuntu. I have never really used virtualbox much. I have always VMware Server. Anyway I messed with it all night, but I can't get it to boot. It starts then throws out some errors which I will screenshot in a moment in case that helps.

  • | Post Points: 35
Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Sat, Jul 4 2009 3:25 PM

Sure - let me know the exact error and I'll give you a hand.

There's normally nothing "special" that needs to be done.

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

  • | Post Points: 5
Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Sun, Jul 5 2009 12:07 PM

Hey Bob,

I decided to try installing from the latest daily Ubuntu LiveCD myself, to see if I could recreate your problem.  The good(?) news is:  I did run into an installation-stopping issue, but I found a way around it.

It looks as if Ubiquity may have some new bug related to ecryptfs.  This caused the Live installer to keep dying on me immediately after formatting the virtual drive.  It might only happen in conjunction with VBox3, but I filed a bug with the Ubiquity devs anyway and attached all the relevant logs just in case.  If they come back with fingers pointed at VBox, I'll open a bug with them.

Here's how I got around it:  Just use the alternate install ISO (http://cdimage.ubuntu.com/daily/current/).  It doesn't have a very pretty GUI, but it works.  :)

The only other thing I did was to make sure I choose the Intel PRO/1000 MT network card in the VBox network settings before doing the installation.  I saw posts on the VBox forums stating that some users were having slowdown issues with at least one of the PCnet options - so I just sidestepped the entire possibility of encountering that problem.

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Sun, Jul 5 2009 1:10 PM

Also, it does indeed look like Compiz works under 3.0:

Compiz in VM

 

Just make sure you install the Linux guest additions, then you'll be able to turn it on under appearance.

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

Top 10 Contributor
Posts 6,181
Points 90,135
Joined: Aug 2003
Location: United States, Virginia
Moderator

Awesome. Thanks. I messed with the settings some and then I didnt get the same bug and was getting something totally different which sounds like the forrmatting issue you had. Which is why I had not got back to you. I'll try the alt CD in a few and see what I get.

  • | Post Points: 20
Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Sun, Jul 5 2009 3:25 PM

The only problem I see so far is that at login/logout, the screenmode doesn't always change to the proper mode for gdm... so you get garbage instead of the login screen.  I'll probably do some more testing and file a bug against the VBox video driver for it.

Here's the workaround for that one, btw:  When you see garbage instead of the login screen, use the host key (right-ctrl, by default) and F2 through F8 to switch to one of the VTY sessions.  Then, press host+F1 to get back to gdm.  It will then switch modes and show the screen properly.

Note:  I discovered that the gui doesn't seem to be on a consistent session/function-key...  It was on host+F7 (where I actually would have expected it to be the first time) when I rebooted.

All in all, it seems to me that Kubuntu and KDE4.3 are getting quite a bit ahead of Gnome.  I'd recommend checking out Kubuntu (http://cdimage.ubuntu.com/kubuntu/daily/current/) instead.

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

Top 10 Contributor
Posts 6,181
Points 90,135
Joined: Aug 2003
Location: United States, Virginia
Moderator

3vi1:
All in all, it seems to me that Kubuntu and KDE4.3 are getting quite a bit ahead of Gnome.  I'd recommend checking out Kubuntu (http://cdimage.ubuntu.com/kubuntu/daily/current/) instead.
Yeah I agree. Gnome has sat pretty stagnant for the last few years. I have been installing the KDE packages and playing around some.I have always like the minimal look of Gnome, but KDE 4 looks very sleek.

  • | Post Points: 5
Top 10 Contributor
Posts 6,181
Points 90,135
Joined: Aug 2003
Location: United States, Virginia
Moderator

Ok so sorry I'm retarded, but I downloaded the CD you linked me to, but now I can't get the guest additions to work. I ran autorun.sh in console and I get this, and nothing installs.

http://img245.imageshack.us/img245/6965/32862708.png - Link to full size pic.

If I run vboxlinuxadditionx86.run nothing happens.

  • | Post Points: 20
Top 10 Contributor
Posts 5,048
Points 60,675
Joined: May 2008
Location: U.S.
Moderator
3vi1 replied on Mon, Jul 6 2009 7:53 AM

Hmmm... that's kind of weird - it looks like it's saying your /tmp path is mounted read-only.  It might just be a security issue though - did you use 'sudo'?

Reboot the VM, use the "Devices/Install Guest Additions" menu option to mount the additions ISO (if it isn't already) and try this from the terminal:

sudo sh /media/cdrom/VboxLinuxAdditions-x86.sh

I'm assuming from your last message that you're using the x86 version instead of the 64-bit version.

If that gives you the same problem, let's see the output of "mount".  If that shows /tmp to be a separate mount that is RO, then we need to make sure it's not misconfigured in /etc/fstab.  If you took the defaults, like me, that shouldn't be the case - your hdd should have a / mount (sda1) for that drive.

Gotta work!  L8r!

What part of "Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn" don't you understand?

++++++++++++[>++++>+++++++++>+++>+<<<<-]>+++.>++++++++++.-------------.+++.>---.>--.

Page 1 of 1 (9 items) | RSS